Using LS Crawler, x-qc-cache: miss

I’m using Lightspeed Cache plugin for Wordpress and Quic Cloud CDN. Everything seems to be set correctly on both ends. Crawler successfully crawls and caches site every 11,000 seconds. However, I am getting x-qc-cache: miss for first visit. Then, second visit is lightning quick with a “hit.” I have Quic cloud set to cache dynamic and static. The cache seems to only store for a very short time - maybe as short as under an hour before I get another “miss.” Why is my site not being cached until I visit a page, even though it’s being crawled???
I’m not sure exactly. I’ll test today to see, but another main issue is the fact that the Lightspeed crawler isn’t caching my quic cloud cache, even though it is showing cached within the plug-in.
I'm using Lightspeed version 4.4.7. If I click "Cache," there are a number of tabs at the top, including "Cache" and "TTL." Under the "Cache" tab, there is no TTL setting listed. If I click the "TTL" tab, there are a number of different TTL settings available, one of of which being the Default Public Cache TTL. It is set at the default value of "604800." That's a week. I have my crawler set to crawl every 8.5 hours. It takes around 2.5 hours to complete and it shows every page cached. At quic cloud, I set my two "CDN-enabled" DNS TTL settings to be 12 hours. So, if my thinking is correct, my crawler should run and refresh quic cloud's cache every 11 hours, giving me a x-qc-cache: hit every time I visit a page, even the first time of the day. Am I missing something?