Not able to install Let's Encrypt SSL on AWS EC2 instance

I have Installed WordPress powered by Lightspeed through Amazon AWS EC2

After Configured EC2 Instance, I Logged into Putty SSH and Connected my Domain to the Litespeed Installation

by selecting Commands YES/NO

I have selected YES when The Command asked for Let's Encrypt SSL.

But everytime it shows "Domain" is inaccessible, please verify!

Always showing "Your domain: " everytime I login to PUTTY SSH

I am using Cloudflare CDN on that domain and it currently showing SSL issued by Cloudflare and no SSL installed in the Origin Server.

My site URL is

How to set up SSL ? Please help
Can you please tell me how to edit this file with FileZilla. Because I tried to edit but no software is there in my PC to edit this type of file.

Is there any command to change this in SSH?


Staff member
Yes, you can edit the script file with vi or vim editor via SSH console.
If you are not familiar with the editor, you can also run the follow command to update the file directly.
sed -i 's/| grep -i LiteSpeed//' /opt/
I tried but it says:

ubuntu@ip-172-31-13-216:~$ sed -i 's/| grep -i LiteSpeed//' /opt/
sed: couldn't open temporary file /opt/sedCYWOTg: Permission denied

What to do next?
Thanks. I have successfully installed SSL on this site. But I failed to install SSL on the subdomains of this site i.e. and The error is like wrong DNS settings:

- The following errors were reported by the server:

Type: tls
Detail: Fetching
remote error: tls: handshake failure

To fix these errors, please make sure that your domain name was
entered correctly and the DNS A/AAAA record(s) for that domain
contain(s) the right IP address. Additionally, please check that
you have an up-to-date TLS configuration that allows the server to
communicate with the Certbot client.
Oops, something went wrong...

I am using Cloudflare CDN on my site. The IP's of the main domain and sub domains are different as all the domains are used on different AWS EC2 instances.

Please help


Staff member
mhm, I just tested the case that both main domain and sub domain are pointing to the same server case and apply LE cert works.
Even you don't apply LE cert manually, you should be able to use free cert from CloudFlare.