litespeed is causing problem with weglot translation plug in? the images are disappearing !

I made a ticket to weglot about the problem with litespeed . but to be sure I want to ask also here because it is also litespeed issue.
when I enable weglot translation plug in and I clean the cache in chrome or I close the website and reopen it all the images are disappearing and the weglot translation plug in is not functioning.
when I disable litespeed then the weglot is functioning normally.
I had such a problem with responsive menu which I made with javascript when I disabled generate UCSS in page optimization the problem was solved .
I want to know if it is possible this problem can be solved in litespeed in some way. maybe disabling some function or maybe excluding some function.
I am using litespeed enterprise from my hosting provider and because this an issue of litespeed so I ask the question here.
how I can fix this problem?


Well-Known Member
when I disable litespeed then the weglot is functioning normally.
you disable lscache (LiteSpeed Cache) - not litespeed

you must understanding - lscache store each url as static HTML file that must contain static references for images and others resources.

if weglot translation plug-in change references for resources then provided by lscache static HTML file from cache can contain missed references.

Last edited: