Cache not in Sync and sometimes missing

Dear all

I've just setup a Server environment with wordpress hosting for a client and facing now an issue with the whole caching. The behaviour is a little bit strange and i spent yesterday hours to figure out what's the root cause but was not successful so far.

Before I share the problem I would like to show you the figure of the environment created with Jelastic. So basically the wordpress cluster environment. I didn't configure anything on my own, besides enabling caching on the Wordpress Litespeed plugin. Wordpress and LSCache Plugin are running on the latest available version.

So actually they are two problems which i currently facing. The first one i've recognized as the page was shown from load to load a little bit different. So i tried to check if the cache is working using:

Sometimes i get the message:
LSCache is supported
LiteSpeed ADC cache is a hit

x-lsadc-cache: hit

So basically what I'm expecting.

Hitting Refresh multiple times results in:
LSCache is supported
x-lsadc-cache: miss

So basically depending on which load balancer of the two nodes the browser is hitting:

The A records in the DNS Zones are configured accordingly to hit either the one or the other LB:
uat-2 3600 IN A
uat-2 3600 IN A

So again, depending on wich LB I'm hitting i getting cached results, or accurated live results, or not. So for instance when I'm changing something on the design logged in and routed via LB 1 I'm not seeing the changes when I reload and hit LB2.

Futhermore I've investigated some configuration on the WebADC. Here's a screenshot:
What is strange over here is that one node is still "Syncing up" and that already since yesterday, so even waiting over night doesn't helped to get that properly running. Restart I've tried as well. So is remaining on "Syncing up" forever, sometimes changing to "out of sync".
What I've also noticed tonight was yesterday a email from Jelastic which sad the following:
this is something strange as well. Most of the time the LB is running more or less idle so I didn't understand that.

So my expectation was mainly that if I'm using the Wordpress Cluster Kit from Jelastic that everything should at least run smoothly after initial fire up. Are they some additional configuration I have to made? is there something missing? I didn't change anything in WebADC or Webserver config as I understood that this configs are all pre configured properly by using Jelastic.

Would be very helpful if you can give me some hints. Furthermore I would be also interested if there is a way to check if the Wordpress to WebADC cache sync via Webserver is working properly. If you need anything else, please let me know.

Kind Regards, Fabo
Hi all

Another thing which I just noticed: When i click on the refresh button on the HA Status Screen I see the following error message:

Best Regards, Fabo