Rails via Mongrel: Litespeed dies upon restart

I've tried about ten times now to follow the directions in http://www.railtie.net/articles/2006/01/21/up-and-running-in-the-speed-of-light, modified to fit the directions at http://weblog.techno-weenie.net/2006/4/11/setting-up-litespeed-with-mongrel. Every time I finish following the directions, the web server dies upon applying the changes and clicking graceful-restart, and can't be brought back up until I reinstall it and go through everything again, at which point it dies once again. I've even tried it with FCGI, just as described in Bob Silva's tutorial.

I have mongrel running fine, as I can access my rails app via one of the ports that mongrel is running on.

If I try to start the server after the inital failure at the command line via
/opt/lsws/bin/lswsctrl start
I get this error:

Can't determine the Home of LiteSpeed Web Server, exit!
[ERROR] Failed to start lshttpd!
If I try to start it as sudo, it will tell me it has started, but the process is subsequently nowhere to be found, and if I run the stop script, it tells me it's not running.

The error.log is not very helpful to my eyes:
2006-05-15 17:35:33.194 [NOTICE] Loading LiteSpeed/2.1.15 Standard ...
2006-05-15 17:35:33.298 [NOTICE] [ADMIN] server socket:
2006-05-15 17:35:33.298 [NOTICE] Loading configuration from /opt/lsws/conf/httpd
_config.xml ...
2006-05-15 17:35:33.299 [INFO] old priority: 0, new priority: 0
2006-05-15 17:35:33.299 [INFO] [config:server:basic] For better obscurity, serve
r version number is hidden in the response header.
2006-05-15 17:35:33.302 [NOTICE] The maximum number of file descriptor limit is 
set to 1024.
2006-05-15 17:35:33.305 [NOTICE] [child: 1305] Successfully change current user 
to www-data
2006-05-15 17:35:33.305 [NOTICE] [Child: 1305] Core dump is enabled.
2006-05-15 17:35:33.305 [NOTICE] [Child: 1305] Setup swapping space...
2006-05-15 17:35:33.306 [NOTICE] [AutoRestarter] new child process with pid=1305
 is forked!
2006-05-15 17:35:33.333 [NOTICE] [Child: 1305] LiteSpeed/2.1.15 Standard starts 
2006-05-15 17:35:34.002 [NOTICE] [AutoUpdate] Checking for new releases...
2006-05-15 17:35:38.343 [INFO] [AutoUpdate] No new update.
2006-05-15 17:37:09.548 [NOTICE] Server restart request from admin interface!
2006-05-15 17:37:09.553 [NOTICE] [Child: 1305] Start shutting down gracefully ..
2006-05-15 17:37:09.553 [INFO] Stop listener *:8088.
Any help you could offer would be greatly appreciated!


LiteSpeed Staff
I think it probably is a permission problem, should not have anything to do with Rails or Mongrel. Can you gracefully restart LSWS from web admin console right after the default installation without making any configuration changes?
Ubuntu disabled root user and uses sudo by default. Which user you were using when you install the server and using the command line script to start stop LSWS?
I've been using sudo to install. I just uninstalled and reinstalled, and a graceful restart (with no configuration) from the web admin worked just fine.
Last edited:


LiteSpeed Staff
There is a bug in vhost access logging configuration in release 2.1.15, please change some configuration under access logging section when you add a new vhost. The bug will be fixed in 2.1.16.