LSWS 1.2 ServletEngine Setup Failure

I'm trying to set up 1.2 to work against Tomcat 5. While 1.1 didn't have a problem, 1.2 fails during the definition of the servlet engine because the autostart radio isn't set (even though I can't set it once the servlet engine type is chosen). I'm thinking this must be a bug; if it's an ABKB error on my end, I'd be more than happy to admit my mistake if someone can help resolve this...


LiteSpeed Staff
Staff member
Thanks for trying the new version and pointing out this. This a bug, we'll fix it and put in a bug fix release 1.2.1 soon. Autostart should be blocked for servlet engine, since tomcat needs to be brought up separately. But this should not prevent you from configuring it.
How do you use our server? in production, development or test? How's your experience with R1.1 on JSP/Serlvet? Any suggestions?

LS@Home ;-)

How do I use LS? Well, it's a combination of all three (eventually). I've got a home grown linux distro sitting behind a firewalled DSL connection. It serves my own domain,, for things that I want to share, and I use it as a test/development box at home for stuff for myself and for work.

In general 1.1 worked well with tomcat, although there seemed to be a problem with non-jsp extensions that are a pain to work around.

As an example, use LS with a generic Tomcat install (with the jsp examples) and try following the links to the source for the JSP pages (it has a .txt extension); for some reason the text was not being returned, it was processed as a regular jsp page...


LiteSpeed Staff
Can't reproduce the extension problem

I just tried it on 1.2.1 with a fresh Tomcat install, the source code is displayed properly.
1.1 should be the same and I could not think of any thing would cause that.
If you still experience that problem with the upcoming 1.2.1, can you please send us a test link to that page?

1.2.1 Did The Trick...

Thanks alot guys! The 1.2.1 version fixed the trick. In testing the config, however, I noticed the following...

When trying the Number Guess Example, the initial page shows, but submission of the page fails with a 404 error from tomcat; however, I don't get it if I connect directly to tomcat via port 8080 (this port is protected via firewall so you won't be able to connect directly yourselves). Although the 404 error is returned, there's nothing in my localhost or catalina log files to indicate tomcat is truly encountering an error.

Any guesses?


LiteSpeed Staff

It is a bug in the AJPv13 interface introduced in 1.2, sending the whole URL including query string, but only URI without query string is expected by tomcat.
The fix will be in 1.2.2. it will be released soon.