Install error xxxx.com is inaccessible, please verify!

#1
Hello, I have recently purchased DigitalOcean servers. And installed Ubuntu.

I have used your 1-Click OpenliteSpeed + Wordpress, everything is OK but doesn't give the SSL certificate.

I have research in Internet and Forums. I go to Let's Encrypt they said it is from your side, not from their side.
I also contacted DigitalOcean, who said that problem is not from they and yes from the script and installation provided by you.

This is the error that appears in DigitalOcean Droplet: example.com is inaccessible, please verify!


Probably, I don't know who have reason or not. But the problem can be solved, I don't know why.

What I did so far:

Reinstalling 1-Click OpenLiteSpeed + Wordpress droplet (Ubuntu)
Added domain to Cloudflare Record A > Domain name pointing to IP
CNAME www poiting to mydomain.com
Disabled Proxy Status in Cloudflare (The Cloudflare IP doesn't appear, appears DigitalOcean IP)
Disabled Cloudflare and tried to use DNS from Domain Registar (Namecheap) configured like Cloudflare CNAME and A Records.

Nothing worked!

I can access my wordpress page with IP and domain, so I don't know what is going on.

I love this 1-Click Openlitespeed + Wordpress, I have bought droplet because of that. I'm so frustrated because I can't use properly. It is a excellent script.
Perhaps one of best in my opinion, my website is so fast and I like the way this is going.

Unfortunately, I can't install SSL and I'm not the only with this issue there are more clients with that, I have read this thread:
https://www.litespeedtech.com/suppo...n-com-inaccessible-please-verify-issue.17454/

Ohh and yes, I tried to make what they said in that thread, even the last one post. None worked.

ssaa2.png

What's going on? I don't know what to do. I did that correctly. I have also go to Youtube and watch some tutorials to see if i'm doing something wrong.
And I'm not.

I love this script, I think I'm not the only with this issue and certaintly there are more users that for sure have left because of this.

How to fix?
 

Pong

Well-Known Member
Staff member
#2
First of all, this is a forum for LiteSpeed Enterprise. You can normally use https://forum.openlitespeed.org/ for OLS related issue.

Second, 1click installation script doesn't handle the Let's Encrypt. You can follow this KB to install let's encrypt using certbot. https://openlitespeed.org/kb/lets-encrypt-ssl-on-openlitespeed/

Third, more easily for you, you should consider to install Cyberpanel+OLS and SSL certificates will be handled by Cyberpanel and should be much easier for you. but cyberpaenl will need to be installed on a bare OS. You can not add Cyberpanel to your exiting server.

Even your https doesn't work due to the SSL certificate issue, your http should be accecciable. If not, it may not be just your SSL certificate issue. you can log a ticket by sending email to support@litespeedtech.com if you still could not resolve your issue.
 
Last edited:
Top