This is an old revision of the document!


“X-LiteSpeed-Cache: hit,litemage” Header Not Appearing (Magento 1.x)

Symptoms

X-LiteSpeed-Cache: hit,litemage header is missing (LiteMage is not working properly)

Cause

There can be various causes for this problem, but most likely a step was missed in the LiteMage 1.x Installation Guide.

Solution

Please double check the following:

  • Do you have LiteMage enabled for your license? For 1-CPU and lower licenses, you will need to purchase LiteMage as an add-on, while LiteMage starter is included in all 2-CPU and above license. If you just recently upgraded your license by adding LiteMage, you will need to register a new license key with command …/lsws/bin/lshttpd -r and restart LSWS.
  • Do you see X-Litespeed-Cache: miss? If yes, just refresh the page again and it will be served from LiteMage.
  • Have you placed LiteMage On in your store's .htaccess file?
  • Do you host your Magento store on a shared hosting service account? Please contact your hosting company to ensure that they have enabled LiteMage for your account.
  • Have you or your host set the server & virtual host level cache root and cache policy?
  • Has Enable LiteMage Cache been set to Yes under LiteMage Configuration in the Magento admin?
  • Have other full page caches been disabled?
  • If you have set Enable LiteMage Cache Only for Listed IPs, is your IP listed?
  • For LiteMage to work correctly, you must have both Configuration and Layouts enabled under System → Cache Management. If you are using Magento Enterprise, you must also disable Page Cache.
  • Did you try flushing LiteMage Cache and Magento Cache Storage?
  • Admin
  • Last modified: 2017/05/05 20:39
  • by Lisa Clarke