Wordpress admin settings don't save when LSWS is active

#1
Hi all, we are having an issue that only happens when we enable LSWS. When Apache is enabled, this issue does not happen.

Just wondering if this is something that any of you have come across and if there is an obvious setting that we have missed.

When LSWS is enabled, we are unable to save some settings in the Wordpress Admin panel. For example if we go into Appearance > Customize > Header Builder > Site Icon and then change the icon to another icon from the media library, save it and refresh the page - the icon is not saved. We have noticed this happening on other new websites we are building since enabling LSWS.

On one of the sites that this is happening on, we are using the Astra theme but this has also happened when using the default wordpress theme and with all plugins disabled. The Litespeed cache plugin is active but Disable All Features is set to On.

Other settings do not save either, for instance global colors. When we deactivate LSWS and enable Apache, the issue goes away and saving can be done as normal.

Any ideas on what we have done wrong? We have followed the online documentation when setting up LSWS and can't see what we are doing wrong. We don't have any virtual hosts.

Thank you for any assistance you can give.
 
#3
Thanks for that info - the only thing is that this is happening regardless of whether the LS cache plugin is installed or not. I can only stop the issue by returning to Apache and disabling LS Web Server.
 
#5
Scratching our heads here. When Litespeed Server is enabled, opcache is enabled and the site is running on php8 - we have issues saving some settings in wp-admin.

If any one of these components is disabled / changed - the issue doesn't persist.
 
#7
I will do that if you can explain why an issue with opcache and Litespeed Web Server would have anything to do with the WP plugin which is not installed on the site we are having issues with - I thought this was a support forum for Litespeed Web Server. I'm not using the WP plugin at this point and I was looking for help with possible configuration errors on our part relating to Litespeed Web Server. I'm not entirely sure why the only reply I keep getting is to use a support forum for a plugin we are not using or having issues with.
 
#8
I thought this was a support forum for Litespeed Web Server.
Yes, but everything that is related to LScache plugin it is only supported at WP support page. If you don't have installed LScache plugin you should ask WP support itself, because you won't get support for an application that isn't LiteSpeed. OPcache is not LiteSpeed related.
 
#9
I'm using Litespeed Web Server Enterprise - I'm asking for support with LSWS. I'm well aware that opcache is not Litespeed related, however, there is lots of documentation relating to how to set up opcache with Litespeed. I'm asking for help with that - I don't need WP support. The issue happens when Litespeed Web Server is enabled. This issue is at server lever. Nothing to do with WP.
 
#11
To anyone who has a similar issue, I'm now getting support from the Litespeed team and it appears that it is PHP related, specifically PHP 8. A support ticket was raised using the support email address. It is not a Wordpress issue and has nothing to do with the LS Cache plugin.
 
#13
To anyone who comes across this issue and has a similar use case to us, here's the solution that the fantastic guys at Litespeed support found for us. Ignore the whole "nothing to do with Litespeed" comment above. As I said in my first message asking for help, "Any ideas on what we have done wrong?". I suspected it was a setting on Litespeed that we had misconfigured and it was just that.

If you have any issues, the guys at Litespeed are more than happy to help, big shout out to Jackson and Gary at Litespeed for the fast responses and help you gave.

The issue in our case was a setting in Server -> PHP -> Run On Startup. When setting up Litespeed Enterprise Web Server, we followed some instructions in the Litespeed documentation on how to set up LSWS to work alongside opcache. Part of those instructions involved putting the server into Daemon Mode but doing that does depend greatly on whether you are operating a dedicated server or a shared hosting environment.

Although we have our own VPS, we have a shared host environment with multiple cPanel accounts - used for different parts of our business. In our use case, the Litespeed team have explained that the setting at Server -> PHP -> Run On Startup should either be blank or "Yes (Detached Mode)".

The issue with saving settings in Wordpress on sites using PHP 8 is now resolved for us.
 
Top