Problems with lsws


Well-Known Member
I installed lsws a few days ago, if the trial will turn out ok, I will buy a license. But, that`s not the issue. I installed lsws the first time, and everything went ok, except that I assigned nobody:nobody to the process. I ran this install several days, switched over to port 80, everything smooth. Then I saw some posts that a reinstall could cure the nobody issue, so I create a user group lsws, user lsws, started the reinstall, selected the right ports and lsws started. I even selected to import the apache conf, after changing lsws port offset corectly. But for my surprise, it doesn`t load httpd.conf. Odd, I turned on apache, moved lsws port offset a bit higher, then I tried to access the pages and it doesn`t work, although, now, the virtualhosts have been loaded. Help, fast !!! Site is launching in 3 days.
Last edited:


Staff member
What's your distro? Centos 8? Ubuntu 20? run LSWs as native, or load apache configuration? all are different. LSWS native will run nobody:nobody on centos and nobody:nogroup on Ubuntu 20. but if you load apache configuration, you should run exactly as apache, apache:apache or
www-data:www-data etc.

Not importing apache conf, LSWS will read apache conf and act directly. You can still modify apache conf and restart LSWS to reload the configuration.

"I create a user group lsws,", no, you should not do that.

moved lsws port offset a bit higher. just set to port offset to 0, and stop apache and start LSWS for testing. To switch back, just stop lsws and start apache. Some application may not work on offset port, just test on 80/443.