Opcode Caching: Disabled


Well-Known Member

Although I've installed OPCache via EA4, I see it is disabled in PHPInfo.


I don't even know if you are to help on this but here I am.

I can see this on the PHPInfo page but not in the INI:



Staff member

Have you tried to restart PHP?
You can do it from WHM > Plugins > LiteSpeed Web Server > Restart Detached PHP Processes



Well-Known Member
It looks enabled:

; Enable Zend OPcache extension module

; Determines if Zend OPCache is enabled

; Determines if Zend OPCache is enabled for the CLI version of PHP

; The OPcache shared memory storage size.

; The amount of memory for interned strings in Mbytes.

; The maximum number of keys (scripts) in the OPcache hash table.
; Only numbers between 200 and 100000 are allowed.

; The maximum percentage of "wasted" memory until a restart is scheduled.

; When this directive is enabled, the OPcache appends the current working
; directory to the script key, thus eliminating possible collisions between
; files with the same name (basename). Disabling the directive improves
; performance, but may break existing applications.

; When disabled, you must reset the OPcache manually or restart the
; webserver for changes to the filesystem to take effect.

; How often (in seconds) to check file timestamps for changes to the shared
; memory storage allocation. ("1" means validate once per second, but only
; once per request. "0" means always validate)

; Enables or disables file search in include_path optimization

; If disabled, all PHPDoc comments are dropped from the code to reduce the
; size of the optimized code.

; If enabled, a fast shutdown sequence is used for the accelerated code

; Allow file existence override (file_exists, etc.) performance feature.

; A bitmask, where each bit enables or disables the appropriate OPcache
; passes


; The location of the OPcache blacklist file (wildcards allowed).
; Each OPcache blacklist file is a text file that holds the names of files
; that should not be accelerated.

; Allows exclusion of large files from being cached. By default all files
; are cached.

; Check the cache checksum each N requests.
; The default value of "0" means that the checks are disabled.

; How long to wait (in seconds) for a scheduled restart to begin if the cache
; is not being accessed.

; OPcache error_log file name. Empty string assumes "stderr".

; All OPcache errors go to the Web server log.
; By default, only fatal errors (level 0) or errors (level 1) are logged.
; You can also enable warnings (level 2), info messages (level 3) or
; debug messages (level 4).

; Preferred Shared Memory back-end. Leave empty and let the system decide.

; Protect the shared memory from unexpected writing during script execution.
; Useful for internal debugging only.

; Allows calling OPcache API functions only from PHP scripts which path is
; started from specified string. The default "" means no restriction

; Enables and sets the second level cache directory.
; It should improve performance when SHM memory is full, at server restart or
; SHM reset. The default "" disables file based caching.
; RPM note : file cache directory must be owned by process owner
;   for mod_php, see /etc/httpd/conf.d/php.conf
;   for php-fpm, see /etc/php-fpm.d/*conf

; Enables or disables opcode caching in shared memory.

; Enables or disables checksum validation when script loaded from file cache.

; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
; This should improve performance, but requires appropriate OS configuration.

; Leads OPcache to check file readability on each access to cached file.
; This directive should be enabled in shared hosting environment, when few
; users (PHP-FPM pools) reuse the common OPcache shared memory.


Staff member
Do you use ea-phpxx? or alt-phpxx? Which one?
Does LiteSpeed have exactly the same php as apache? (you can switch between apache and litespeed and compare phpinfo.php)
If ea-phpxx, try to uninstall opcode cache from WHM easy apache 4 (check phpinfo.php with apache to make sure it is gone ) and then resintall opcode cache from WHM easy apache 4( check phpinfo.php with apache to make sure it is back), if it works on apache, it should just work with LiteSpeed. if problem persists on apache even, I would recommend you to log a ticket with cpanel support to take a look.


Well-Known Member
Yes, still. I was told to disable suEXEC. Today I disabled it. And then immediately, I got errors in Xenforo:

All directories under ....public_html/sosyal/internal_data must be writable. Please change the permissions on these directories to be world writable (chmod 0777).
I've chmodded internal_data and data but still got this image problem:


And on the Wordpress site, I started getting this error:

Warning: ftp_fget() expects parameter 1 to be resource, null given in /home/technopa/public_html/wp-admin/includes/class-wp-filesystem-ftpext.php on line 146

Warning: Cannot modify header information - headers already sent by (output started at /home/technopa/public_html/wp-admin/includes/class-wp-filesystem-ftpext.php:146) in /home/technopa/public_html/wp-includes/functions.php on line 6274

Warning: Cannot modify header information - headers already sent by (output started at /home/technopa/public_html/wp-admin/includes/class-wp-filesystem-ftpext.php:146) in /home/technopa/public_html/wp-admin/includes/misc.php on line 1310

Warning: Cannot modify header information - headers already sent by (output started at /home/technopa/public_html/wp-admin/includes/class-wp-filesystem-ftpext.php:146) in /home/technopa/public_html/wp-admin/admin-header.php on line 9
Solved this error with pasting define('FS_METHOD','direct'); code into config.php but still could not install add-ons...

So, my first attempt at disabling suEXEC failed. I might give it a try if you can help me more. XenForo admins told me that I should have also performed chown.