[solved] 500 Error, Redirection Loop on Webmail, Cpanel etc

Discussion in 'General' started by chrisando, May 16, 2014.

  1. chrisando

    chrisando New Member

    Hello,

    Problem:
    Going to webmail.domain.com or cpanel.domain.com will timeout with a 500 Internal Server Error.

    Restarting Litespeed - fixes the problem temporarily.
    Switching to Apache - fixes the problem permentantly.
    I have CloudLinux, Turning this off, does not change anything.
    Using domain.com/webmail shows no issue.
    Using domain.com:2095 shows no issue either.

    Version: Litespeed Web Server Enterprise v4.2.10

    Error Log (/usr/local/apache/logs/error_log) shows, when attempting to access webmail.domain.com

    Code:
    2014-05-16 11:43:29.903 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:80 182.160.157.154:80 182.160.159.228:80 182.160.159.229:80 182.160.159.230:80 12] connection to [127.0.0.1:2095] on request #1, confirmed, 0, associated process: -1, running: 0, error: Input/output error!
    2014-05-16 11:43:29.904 [NOTICE] [110.143.182.227:53703-0#APVH_182.160.136.244:80 182.160.157.154:80 182.160.159.228:80 182.160.159.229:80 182.160.159.230:80 12] Max retries has been reached, 503!
    2014-05-16 11:43:29.904 [NOTICE] [110.143.182.227:53703-0#APVH_182.160.136.244:80 182.160.157.154:80 182.160.159.228:80 182.160.159.229:80 182.160.159.230:80 12] oops! 503 Service Unavailable
    2014-05-16 11:43:29.904 [NOTICE] [110.143.182.227:53703-0#APVH_182.160.136.244:80 182.160.157.154:80 182.160.159.228:80 182.160.159.229:80 182.160.159.230:80 12] Content len: 0, Request line: 'GET / HTTP/1.1'
    2014-05-16 11:43:29.904 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:80 182.160.157.154:80 182.160.159.228:80 182.160.159.229:80 182.160.159.230:80 12] Cookie len: 168, webmailrelogin=no; webmailsession=%3as33m12WaURu3u7UTmAf0d0Gki6dYC7o3RvAawQcnR772CMVv2_UolcpmbzXvjxp4%2c043665e5c9f44fcd838cdedf60d021e7a17eb6df3c6e24f3e142703d185e383a
    2014-05-16 11:43:29.904 [NOTICE] [110.143.182.227:53703-0#APVH_182.160.136.244:80 182.160.157.154:80 182.160.159.228:80 182.160.159.229:80 182.160.159.230:80 12] Redirect: #1, URL: /
    2014-05-16 11:43:29.904 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:80 182.160.157.154:80 182.160.159.228:80 182.160.159.229:80 182.160.159.230:80 12] abort request..., code: 4
    2014-05-16 11:43:34.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Connection idle time: 121 while in state: 5 watching for event: 25,close!
    2014-05-16 11:43:34.361 [NOTICE] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Content len: 0, Request line: 'GET / HTTP/1.1'
    2014-05-16 11:43:34.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Cookie len: 168, webmailrelogin=no; webmailsession=%3as33m12WaURu3u7UTmAf0d0Gki6dYC7o3RvAawQcnR772CMVv2_UolcpmbzXvjxp4%2c043665e5c9f44fcd838cdedf60d021e7a17eb6df3c6e24f3e142703d185e383a
    2014-05-16 11:43:34.361 [NOTICE] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Redirect: #3, URL: /503.shtml
    2014-05-16 11:43:34.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] HttpExtConnector state: 0, request body sent: 0, response body size: 0, response body sent:0, left in buffer: 0, attempts: 0.
    2014-05-16 11:43:34.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Proxy connection state: 2, watching event: 25, Request header:0, body:0, sent:0, Response header: 0, resp body: 0 bytes received in 0 seconds,Total processing time: 5.
    2014-05-16 11:43:34.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] abort request..., code: 4
    2014-05-16 11:43:35.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Connection idle time: 122 while in state: 5 watching for event: 25,close!
    2014-05-16 11:43:35.361 [NOTICE] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Content len: 0, Request line: 'GET / HTTP/1.1'
    2014-05-16 11:43:35.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Cookie len: 168, webmailrelogin=no; webmailsession=%3as33m12WaURu3u7UTmAf0d0Gki6dYC7o3RvAawQcnR772CMVv2_UolcpmbzXvjxp4%2c043665e5c9f44fcd838cdedf60d021e7a17eb6df3c6e24f3e142703d185e383a
    2014-05-16 11:43:35.361 [NOTICE] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Redirect: #5, URL: /500.shtml
    2014-05-16 11:43:35.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] HttpExtConnector state: 0, request body sent: 0, response body size: 0, response body sent:0, left in buffer: 0, attempts: 0.
    2014-05-16 11:43:35.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] Proxy connection state: 2, watching event: 25, Request header:0, body:0, sent:0, Response header: 0, resp body: 0 bytes received in 0 seconds,Total processing time: 1.
    2014-05-16 11:43:35.361 [ERROR] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] detect loop redirection: /500.shtml
    2014-05-16 11:43:35.361 [INFO] [110.143.182.227:53703-0#APVH_182.160.136.244:proxy] abort request..., code: 4 

    Any pointers, or suggestions?

    Thanks
    Chris
  2. NiteWave

    NiteWave Administrator

  3. tina

    tina Member

    4.2.11 resolves this issue, but creates another issue.

    You can now login to cpanel.domain.com or webmail.domain.com once, then when you logout, and try to login again, you will see the following error message:

    A network error occurred while sending your login request. Please try again. If this condition persists, contact your network service provider.

    If you then try a different web browser, the same problem occurs. First time okay, subsequent times error.
  4. mistwang

    mistwang LiteSpeed Staff

    please try 4.2.12

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.12
  5. tina

    tina Member

    Thank you, it fixed the problem! :)

Share This Page