problem with wsgi for Django in litespeed

Discussion in 'General' started by M4hdi, May 17, 2014.

  1. M4hdi

    M4hdi New Member

  2. NiteWave

    NiteWave Administrator

    M4hdi likes this.
  3. M4hdi

    M4hdi New Member

    hello

    thank you for help me :X

    i configured my lsws wsgi with your link.

    now i see 500 internal server error in wsgi hello world !!!

    this image is form my lsws panel an i see this errors :
    http://i.cubeupload.com/9S4U5P.png

    Please Help ME :X

    Thank You
  4. NiteWave

    NiteWave Administrator

    can you give a screenshot of your configuration regarding Server->External App->wsgiApp
    M4hdi likes this.
  5. M4hdi

    M4hdi New Member

  6. NiteWave

    NiteWave Administrator

    it looks ok and no problem

    then
    1.show the configuration of "Script Handler" of wsgi
    2.which folder you put hello.wsgi ? and the URL to access it ?
    M4hdi likes this.
  7. M4hdi

    M4hdi New Member

  8. NiteWave

    NiteWave Administrator

    Last edited: May 18, 2014
    M4hdi likes this.
  9. M4hdi

    M4hdi New Member

  10. NiteWave

    NiteWave Administrator

    it's weird ..

    it's a WHM/cPanel server ? please check
    /usr/local/apache/logs/error_log
    /usr/local/apache/logs/stderr.log
    for related errors.
    M4hdi likes this.
  11. M4hdi

    M4hdi New Member

    yes my server is Cpanel/Whm

    i can't see error in error_log

    please helo me ....
  12. NiteWave

    NiteWave Administrator

    the full path of m4.wsgi ? and its permission ?
    #ls -l m4.wsgi
    and content ?

    or you can PM me the access to the server, I can have a quick look.
    M4hdi likes this.
  13. M4hdi

    M4hdi New Member

    i chmoded m4.wsgi to 755 !

    this ls -l m4.wsgi :
    -rwxr-xr-x 1 root root 149 May 18 08:18 m4.wsgi


    Please Helo Me :X
  14. NiteWave

    NiteWave Administrator

    the owner is root. what's the owner of index.php in same folder ?
    #ls -l index.php
    M4hdi likes this.
  15. M4hdi

    M4hdi New Member

    oh yes

    -rw-r--r-- 1 fastwebh fastwebh 418 Sep 25 2013 index.php

    i deleted m4.wsgi and make m4.wsgi new from cpanel.
    owner is :
    -rwxr-xr-x 1 fastwebh fastwebh 149 May 18 21:23 m4.wsgi

    and my problem is not fix !!!!
  16. NiteWave

    NiteWave Administrator

    #chmod a-x m4.wsgi

    so m4.wsgi has same permission and owner/group with index.php
    M4hdi likes this.
  17. M4hdi

    M4hdi New Member

    i chmoded to : chmod a-x m4.wsgi

    and it is not fix !!!

    pleas Help MEE
  18. NiteWave

    NiteWave Administrator

    I need collect more info to troubleshooting.
    you PM me the server's root access, this is the fastest way to help you.
  19. mistwang

    mistwang LiteSpeed Staff

    For wsgiApp, you need to set "Instances" to 1. Memory soft/hard limit should be set high enough, Process soft/hard limit should be set high enough.
    check /usr/local/apache/logs/error_log and stderr.log for related errors.

Share This Page