Images issue with OSCommerce

Discussion in 'Bug Reports' started by RampantLion, Jun 10, 2014.

  1. RampantLion

    RampantLion New Member

    I currently use OSCommerce version 2.3.1 and for the past 5 or 6 LiteSpeed updates, I have a problem where some images will not load. Since all of the images are in the same directory and have the same attributes, I am baffled as to what is happening. I have "fixed" this from time to time by restarting the server, but now (and a few other times), this is not doing anything. When you go to my shopping cart system, random images do not load. When I click on the text where the images should be, it says The requested content cannot be loaded. Please try again later. I have tried for months to find help, but most techs are not knowledgeable regarding LiteSpeed. At one point, I was able to get around this by reverting to older versions of Litespeed, but I just upgraded servers and I no longer have that option. I also feel safer using the most up-to-date versions.
  2. RampantLion

    RampantLion New Member

    What I've noticed is that if images in the directory are set to 777, if I attempt to chmod them to 755, it isn't allowing me to. I've tried with FlashFXP and even in the SSH console. If I manually download the image, delete it from the directory, re-upload it, chmod the image attibutes to 755 and then restart Litespeed, the images will load. But this isn't realistic with 1000s of images.
  3. NiteWave

    NiteWave Administrator

    really weird issue. can you post the settings of:
    lsws web admin -> Server -> Security -> File Access

Share This Page